mac OS Catalina, Xcode 12.4 “Unsupported OS version” after iPhone iOS update 14.6, 老xcode如何支持新iphone os版本?

 ios, mac  mac OS Catalina, Xcode 12.4 “Unsupported OS version” after iPhone iOS update 14.6, 老xcode如何支持新iphone os版本?已关闭评论
7月 252021
 

老xcode如何支持新iphone os版本?(mac OS Catalina, Xcode 12.4 “Unsupported OS version” after iPhone iOS update 14.6 solved)

问题: iphone升级到了14.6, 但macOS还停留在Catalina 10.15.7, xcode只能升级到12.4,使用iphone调试app时提示 “Unsupported OS version” ,无法编译真机运行调试,难道只能升级mac OS并顺便升级Xcode,如果碰到老的mac,无法升级OS,难道就束以待毙,无法调试了吗??感谢万能的互联网和一群热心的网友!

解决方法:

  • . 打开Finder
    . 打开应用程序文件夹
    . 在里面找到Xcode应用
    . 点击Xcode,右键 -> 显示包内容
    . 在里面按下面目录层级找到支持的真机测试文件:Contents -> Developer -> Platforms -> iPhoneOS.platform -> DeviceSupport(/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport), 这个目录里面就是当前Xcode支持真机调试的真机iOS版本
    . 然后通过拷贝最新的DeviceSupport文件到这个目录里面就可以用最新的iOS设备真机调试了。可以通过哪些渠道获取DeviceSupport文件呢? https://github.com/iGhibli/iOS-DeviceSupport 这个网址收集了迄今为止所有支持的包,大家自行下载即可! 或者也可以到其它同学新的xcode下copy对应的目录过来也可以!

如:

IOS 14.5 (FromXcode_12.5)

IOS 14.6 (FromXcode_12.4)

下载DeviceSupport全集来源: https://github.com/iGhibli/iOS-DeviceSupport

 

DONE!

 

“此版本…不能安装在这台电脑上”问题解决,旧/老Mac如何安装通过patch包安装不兼容的High Sierra, Mojave,Catalina系统

 mac, macpro  “此版本…不能安装在这台电脑上”问题解决,旧/老Mac如何安装通过patch包安装不兼容的High Sierra, Mojave,Catalina系统已关闭评论
3月 282021
 

老版的macpro , 比如2011年的版本正常升级系统只能支持到High Sierra, 而无法安装Mojave,Catalina系统, 但实际老硬件支持这些系统毫无压力,如果还换过固态硬盘的话,运行新操作系统更是绰绰有余,那如何升级呢?

老外做了一些补丁包,可以从以下址http://dosdude1.com/software.html下载到对应的包。

 

我们以安装mojave patch为例,以下所有的内容都可以在它的网页上找到(http://dosdude1.com/mojave/),我只是翻译成了中文,便于大家阅读:

 

具体步骤如下:

一、前提条件:

  1. 下载好对应的 mojave patch.
  2. 准备一个U盘,最好16G以上,
  3. macOS Mojave安装程序应用程序的副本。可以使用支持Mojave的机器从Mac App Store获得此信息,也可以使用mojave patch该工具的内置下载功能获得该信息。在菜单栏中,只需选择“工具>下载macOS Mojave …”http://dosdude1.com/mojave/tutorialimages/downloadMacOS.png

 

二、使用方法:

重要说明: 如果您有一台本机支持High Sierra的计算机,则要从APFS卷启动,必须​​确保安装了系统的最新版本的BootROM。如果您以前未安装High Sierra,您可以下载并安装这个软件包以安装最新的BootROM版本。安装时,请确保系统已接通电源,否则将不会安装更新。

1.插入所需的USB驱动器,打开“磁盘工具”,然后将其格式化为OS X扩展(日志式)。

2.打开“ macOS Mojave Patcher”工具,然后浏览以找到macOS Mojave Installer应用程序的副本。

*确保该工具成功验证了应用程序。

3.接下来,在“目标卷”列表中选择您的USB驱动器,然后单击“开始操作”。

4.操作完成后,通过在打开计算机电源的同时按住Option键并选择驱动器,从刚创建的USB驱动器上启动目标不受支持的Mac。


注意:如果要进行全新安装,请仅执行步骤5和6。否则,您只需跳过这些步骤并安装到包含OS X早期版本的卷中,它将进行就地升级。

5.安装程序启动后,从“实用工具”菜单中打开“磁盘实用工具”,或者在屏幕左下角的“实用工具”窗口中双击它。

6.选择要安装在其上的磁盘或分区,然后将其擦除,以确保使用Mac OS Extended(日志式)或APFS作为文件系统类型。如果格式化整个驱动器,请确保已选择GUID。

重要的提示:  Mojave中要求使用APFS,以便通过常规软件更新方法接收系统更新。如果您选择继续使用macOS Extended(Journaled)作为文件系统类型,则不会通过系统偏好设置接收系统更新。

•在2009年末及以后的计算机上使用APFS的工作方式与High Sierra相同。
•如果您的机器本身不支持High Sierra(因此无法自然启动APFS卷),请注意以下几点:

—如果使用APFS,将没有可启动的恢复分区。
—如果您决定使用APFS,则安装后的工具将安装自定义启动方法,因为这些不受支持的计算机的固件本身不支持从APFS卷启动。它不像本机启动那样干净,但是在运行Mojave时不会引起任何问题。修改后的启动过程的演示可以在这里查看。

7.将macOS正常安装到所需的卷上。

8.安装完成后,重新引导回安装程序驱动器。这次,打开“ macOS Post Install”应用程序。

9.在应用程序中,选择您正在使用的Mac型号(如果不清楚型号的,可以点击mac左上角苹果图标,点击 “关于本机”  –> “概览” –> “系统报告……” –> “硬件”, 在“硬件概览”下的“型号标识符“就是我们要找的信息)。将根据您选择的模型为您选择最佳的补丁。您还可以选择其他补丁。

10.选择刚刚在其上安装了macOS Mojave的卷,然后单击“修补程序”。完成修补后,单击“重新启动”。在重新启动之前,它可能会坐在那里片刻来重建缓存。
•如果由于某种原因,系统在重新引导后无法正常运行,请重新引导至安装程序驱动器,再次运行安装后修补程序,然后在重新引导之前选择“强制缓存重建”。在大多数情况下,这不是必需的。

11.重新启动后,它现在应该启动到macOS Mojave的完全正常工作的副本中。

附加信息:

•如果在macOS后期安装工具中选择了Mojave,则您的Mojave安装将在/ Applications / Utilities文件夹中有一个名为“ Patch Updater”的程序。当您的计算机有可用的补丁程序新更新时,此程序将提醒您,并提示您安装它们。如果您没有安装补丁更新程序,但是想要安装它,则可以下载并运行此处找到的脚本。

•在系统更新期间,某些补丁可能会被覆盖。使用补丁更新程序工具,可以一键式重新安装这些补丁。为此,请打开Patch Updater应用程序,然后选择“查看已安装的更新”,或使用菜单栏中的“查看>显示已安装的更新”菜单。
•要重新安装补丁,只需在列表中右键单击它,然后选择“重新安装”。您也可以选择“全部重新安装”按钮,以立即重新安装所有当前已安装的修补程序。

更新

重要说明:

    • Mojave中要求使用APFS,以便通过常规软件更新方法接收系统更新。如果您选择继续使用macOS Extended(Journaled)作为文件系统类型,则不会通过系统偏好设置接收系统更新。如果您不使用APFS,则可以按照以下10.14.1的安装步骤进行操作。

 

  • 通过软件更新应用任何系统更新后,很有可能需要使用Mojave Patcher安装程序卷重新应用安装后补丁。如果您安装软件更新,但系统随后无法启动,则需要执行此操作。

 

下载官网旧版 macOS, 老版OS X, macOS官网连接地址(Catalina,Mojave,Sierra,Capitan,Yosemite)

 mac  下载官网旧版 macOS, 老版OS X, macOS官网连接地址(Catalina,Mojave,Sierra,Capitan,Yosemite)已关闭评论
2月 252021
 
apple官网下载老版OS 系统的链接实在太难找了,而其它网站上下载要么不能用,那么这注册那注册, 我整理了下官网os网页上的内容,大家可以选择下载,纯正官网噢!!!

下载旧版 macOS

下载和安装 macOS 需要花费一些时间,因此请确保您已接入交流电源并具备可靠稳定的互联网连接。

以下来自 App Store 的安装器会在您下载后自动打开:

您的网页浏览器会以名为“InstallOS.dmg”或“InstallMacOSX.dmg”的磁盘映像的形式下载以下较早版本的安装器。请打开磁盘映像,再打开其中的 .pkg 安装器。它将安装一个名为“安装 [版本名称]”的 App。请从“应用程序”文件夹中打开这个 App,以开始安装操作系统。

附官网创建可引导盘链接:

macos 10.15.x catalina could not be verified/ xcode 11 An unknown error occurred. See the install log for more details.

 mac, macpro, xcode, 开发  macos 10.15.x catalina could not be verified/ xcode 11 An unknown error occurred. See the install log for more details.已关闭评论
1月 202020
 

2012 macpro  升级 macos 到 10.15.2  catalina  并 安装 新xcode时碰到下列问题,供其他碰到的同学参考。

  • 问题1.  “macOS Catalina” could not be verified, 在”系统偏好设置 ” -> “软件更新”下下载完catalina更新包后点安装,提示  “macOS Catalina” could not be verified.
    解决办法:打开“ 系统偏好设置”->“日期与时间”->去掉打勾”自动设置日期与时间”, 重启机器,并再次软件更新并安装。

Go to settings then date&time. Click and then unclick “set date and time automatically”. Save the changes by clicking the lock.

Then restart the computer and proceed to download the update once again through settings and software update. It resolved the issue of the update not being verified.

 

  • 问题2. macos catalina安装完,打开xcode时,提示“An unknown error occurred. See the install log for more details.”

解决方法:

  • 这个问题再次在Xcode 11.1出现,是有个证书在2019年的10月份某天过期引起的。
  • 你可以通过暂时把系统日期修改到过期的日期之前来解决。
  • 在Xcode 11这个版本下,设置系统日期为2019年10月3日,然后运行Xcode,再安装组件,(就可以安装成功了),完成之后再把系统日期改回正常状态。
  • This problem has once again appeared in Xcode 11.1 and is caused by an invalid certificate that expired some day in October 2019.
  • You can work around the problem by temporarily changing the system date to before the certificate expiration date.
  • In the case of Xcode 11, set the system date to Oct 3, 2019, run Xcode, then change the date back after the components have installed.

苹果公司就这么把版本放出来也是醉了!