xcode-select: error: tool ‘genstrings’ requires Xcode, but active developer directory ‘/Library/Developer/CommandLineTools’ is a command line tools instance 解决

 xcode  xcode-select: error: tool ‘genstrings’ requires Xcode, but active developer directory ‘/Library/Developer/CommandLineTools’ is a command line tools instance 解决已关闭评论
9月 092019
 

使用xcode时 在终端使用 genstrings命令时, 却提示: xcode-select: error: tool ‘genstrings’ requires Xcode, but active developer directory ‘/Library/Developer/CommandLineTools’ is a command line tools instance, 可以使用下面的方法解决:

1. 打开xcode, 进入Xcode -> preferences 菜单,或者直接快捷键command + , 进入菜单。
2. 在Locations这个tab下,找到 “Command Line Tools” ,在这个组合框里选择对应的xcode版本即可,我机器选择的是:Xcode 10.2.1(10E1001)

DONE!